Welcome, Guest
Username: Password: Remember me
Sharpener and Accessory Maintenance
  • Page:
  • 1
  • 2

TOPIC: New WE Owner Question

Re: New WE Owner Question 1 year 9 months ago #7404

  • wickededge
  • wickededge's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1781
  • Thank you received: 646
  • Karma: 91
Oldguy wrote:
I am apparently missing something.

The paperstone base is 1-1/4" thick and the mounting screws are 1-1/2" long overall (1-3/8" thread length-excludes the flat, countersink screw head). If I add the washer (metal/rubber) as I originally asked about, there is not enough male screw thread protruding from the top of the paperstone base to be able to engage the sharpener base female thread.

Surely I am doing something incorrectly.

Sorry to be such a bother, but...

Thank you.

If you push the screws through the washers, then the base and they stick out enough to get a little thread engagement with the sharpener base, then that should be enough because the washers will compress quite a bit and then you'll have plenty of thread engagement. Please let me know if that works. Otherwise, we might have sent the wrong screws.
--Clay Allison
The administrator has disabled public write access.

Re: New WE Owner Question 1 year 9 months ago #7408

  • cbwx34
  • cbwx34's Avatar
  • OFFLINE
  • Moderator
  • Posts: 1260
  • Thank you received: 413
  • Karma: 92
I pulled my screw out and measured... it's 1 1/2 in. long, so I think you got the right screws.

Here's a photo of how it looks on the bottom of the base....

BaseWashers.jpg
The administrator has disabled public write access.
The following user(s) said Thank You: leomitch
  • Page:
  • 1
  • 2
Time to create page: 0.120 seconds