Welcome, Guest
Username: Password: Remember me
Sharpener and Accessory Maintenance
  • Page:
  • 1
  • 2

TOPIC: New WE Owner Question

New WE Owner Question 1 year 9 months ago #7391

  • Oldguy
  • Oldguy's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 3
  • Karma: 4
Hooray, my Pro-Pack is here!

But...as suggested, I performed an inventory of the items in the package and found two washers enclosed that do not seem to be referenced in the documentation. They were packaged together and can be described as follows: o/s diameter = 1/2"; i/s diameter = 1/8"; construction = two ply, convex side is metal and concave side is a rubber-like material. The only application I can see for them is perhaps serving as retention devices for the thumb screws on the guide rod hinge collars.

Please advise. Thank you in advance!
The administrator has disabled public write access.
The following user(s) said Thank You: leomitch

Re: New WE Owner Question 1 year 9 months ago #7392

  • wickededge
  • wickededge's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1801
  • Thank you received: 649
  • Karma: 92
Oldguy wrote:
Hooray, my Pro-Pack is here!

But...as suggested, I performed an inventory of the items in the package and found two washers enclosed that do not seem to be referenced in the documentation. They were packaged together and can be described as follows: o/s diameter = 1/2"; i/s diameter = 1/8"; construction = two ply, convex side is metal and concave side is a rubber-like material. The only application I can see for them is perhaps serving as retention devices for the thumb screws on the guide rod hinge collars.

Please advise. Thank you in advance!

Good question, thanks for asking. They go on the #10-32 screws that mount the Paperstone base to the sharpener. The rubber side goes against the base and the metal side against the screw head.
--Clay Allison
The administrator has disabled public write access.

Re: New WE Owner Question 1 year 9 months ago #7393

  • Oldguy
  • Oldguy's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 3
  • Karma: 4
Well, than makes sense too-thanks so much for the fast response!!!

I have high hopes for this WE sharpening system as I have been sorely disappointed with the parade of others, manual (including the Edge-Pro) and electric, that I have tried over the years.

Thanks again!
The administrator has disabled public write access.

Re: New WE Owner Question 1 year 9 months ago #7394

  • leomitch
  • leomitch's Avatar
  • OFFLINE
  • Administrator
  • Posts: 721
  • Thank you received: 209
  • Karma: 92
Hi Louis!
Good to have you here!
Sorry to hear of your disappointments with other systems, but I can almost guarantee you that you will feel differently about the WEPS...it rocks!
Welcome aboard Louis!

Warm regards
Leo
Never go anywhere without your knife!
Gibbs rule number 9

Leo James Mitchell
The administrator has disabled public write access.

Re: New WE Owner Question 1 year 9 months ago #7395

  • DAUG
  • DAUG's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 92
  • Thank you received: 19
  • Karma: 8
Welcome to the forum, OG

Good thing Clay cleared up where to place those washers. You're one step closer to give the WEPS a go and don't get frustrated with your first sharpening experience. As you spend more time on this forum you'll discover that we've all learned to make our (less than adequately) sharp knives dull before we learned to get them razor sharp. It just takes a few practice sessions to perfect you're technique then you'll be really surprised what you can do with it.

Oh and BTW, welcome to your new addiction!
The administrator has disabled public write access.

Re: New WE Owner Question 1 year 9 months ago #7397

  • BobNash
  • BobNash's Avatar
  • NOW ONLINE
  • Gold Boarder
  • Posts: 165
  • Thank you received: 63
  • Karma: 84
Welcome to the forum OG - have fun with your new Wicked Edge and let us know how it is going :cheer:
Some of the edges I've sharpened on the WE
www.oldawan.com
This email address is being protected from spambots. You need JavaScript enabled to view it.
505-570-2040 (mobile and office)
The administrator has disabled public write access.
The following user(s) said Thank You: WayneNicklin

Re: New WE Owner Question 1 year 9 months ago #7399

  • JamesBell
  • JamesBell's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 65
  • Thank you received: 14
  • Karma: 9
Welcome OG , good to have you on-board!

One trick I have learned, by default the Forum places you in the "Recent Topics" tab, and that is good it should do that. Do use the "Index" tab, it is easier to find topics that will help answer question. Along with the WE Wiki found under "Resources" there are tons of great reading and photos. It's a wonderful group of members on this Forum, good to have you with us.
- James
The administrator has disabled public write access.

Re: New WE Owner Question 1 year 9 months ago #7400

  • FredHermann
  • FredHermann's Avatar
  • OFFLINE
  • Gold Boarder
  • Posts: 208
  • Thank you received: 41
  • Karma: 18
Yes, welcome!
You're in for a fun ride.
This system is nothing short of amazing.
Before you get too crazy, scan some of the posts for set up and care tips. We've each made our own mods to our kits to suit our tastes, not everything will match your style, but some are nothing short of amazing.
And keep us posted!
“On one otherwise normal Tuesday evening I had the chance to live the American dream. I was able to throw my incompetent jack*ss of a boss from a fourteenth-story window.”

Owen Pitt – Monster Hunter International
The administrator has disabled public write access.

Re: New WE Owner Question 1 year 9 months ago #7401

  • Oldguy
  • Oldguy's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 3
  • Karma: 4
Thanks all!!!
The administrator has disabled public write access.

Re: New WE Owner Question 1 year 9 months ago #7402

  • Oldguy
  • Oldguy's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 3
  • Karma: 4
I am apparently missing something.

The paperstone base is 1-1/4" thick and the mounting screws are 1-1/2" long overall (1-3/8" thread length-excludes the flat, countersink screw head). If I add the washer (metal/rubber) as I originally asked about, there is not enough male screw thread protruding from the top of the paperstone base to be able to engage the sharpener base female thread.

Surely I am doing something incorrectly.

Sorry to be such a bother, but...

Thank you.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.169 seconds