Welcome, Guest
Username: Password: Remember me
Sharpener and Accessory Maintenance

TOPIC: can't get the clamp and riser mounted correctly?

can't get the clamp and riser mounted correctly? 1 year 6 months ago #10218

  • DannBoland
  • DannBoland's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 2
  • Karma: 0
Hi,

Just received my pro pack II upgrade. I can't seem to get a good fit of the base rod onto the base, riser, and clamp. I'm thinking that the 2" socket cap screw may bejust a little too long, so it tightens in the clamp before it reaches the bottom of the base rod? I can grind off a bit, but wanted to see if anyone else had seen this?

Thanks
Dan
The administrator has disabled public write access.

Re: can't get the clamp and riser mounted correctly? 1 year 6 months ago #10219

  • cbwx34
  • cbwx34's Avatar
  • OFFLINE
  • Moderator
  • Posts: 1260
  • Thank you received: 413
  • Karma: 92
Hey Dan... welcome to the forum

Haven't seen this as an issue that I recall.

I took mine apart and screwed the screw directly into the clamp, and it appears to go in 3/8 of an inch. Does yours go in that far? Maybe that'll narrow down the problem. If it doesn't, I guess you could take a bit off, but not having done that, I don't know if there would be any issue... I guess just be careful not to cross thread it when you put it together.

Let me know what you figure out.
The administrator has disabled public write access.

Re: can't get the clamp and riser mounted correctly? 1 year 6 months ago #10220

  • jasonls63
  • jasonls63's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 1
  • Karma: 0
I received my WE PP2 today and had the same issue. I called and Kyle said someone else had the same problem today (maybe that was you). He is sending out a shorter screw priority. I tried washers, but that caused the screw head to be to low. I thought about grinding the screw shorter, but instead of risking the threads am choosing to wait for the screw from Kyle.

Thanks to Kyle at WickedEdge for getting all over this little hiccup.
The administrator has disabled public write access.
The following user(s) said Thank You: cbwx34

Re: can't get the clamp and riser mounted correctly? 1 year 6 months ago #10222

  • cbwx34
  • cbwx34's Avatar
  • OFFLINE
  • Moderator
  • Posts: 1260
  • Thank you received: 413
  • Karma: 92
Good to know, thanks for the heads up!
The administrator has disabled public write access.

Re: can't get the clamp and riser mounted correctly? 1 year 6 months ago #10224

  • DannBoland
  • DannBoland's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 2
  • Karma: 0
Yp, that was it. I tried a washer, it tightned the clamp, but then body didn't fit the base quite right. I waited long enough for the upgrade, can wait a couple more days for the shorter screw.

Thanks folks for the quick replies!
The administrator has disabled public write access.

Re: can't get the clamp and riser mounted correctly? 1 year 5 months ago #10260

  • DannBoland
  • DannBoland's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 2
  • Karma: 0
Thanks to Kyle. Replacement screws arrived yesterday and the shorter one did the trick! What great customer service!

And just in time to sharpen every knife in the roll before barbecue season starts!
The administrator has disabled public write access.
The following user(s) said Thank You: wickededge, cbwx34
Time to create page: 0.125 seconds