Welcome, Guest
Username: Password: Remember me
Sharpener and Accessory Maintenance

TOPIC: Question

Question 1 year 6 months ago #10156

  • MarkMassie
  • MarkMassie's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 43
  • Thank you received: 3
  • Karma: 0
Hello Everyone,

I have been having a great time sharpening knives with the WEPS and learning from all of you on this forum but am struggling in one area and am looking for some guidance. It seems that every knife I sharpen the left (with the knife in the clamp) bevel is always a little wider than the right I am using the angle gauge and eye sight to ensure the knife is in the clamp straight left and right, ensuring the angle is the same with all stones and ceramics but not the strops. Is there anything else other than the knife not bring perfectly straight in the clamp that I am overlooking that could be causing this?

Thanks in advance for anu input on this!

Mark
The administrator has disabled public write access.

Re: Question 1 year 6 months ago #10160

  • cbwx34
  • cbwx34's Avatar
  • OFFLINE
  • Moderator
  • Posts: 1260
  • Thank you received: 413
  • Karma: 92
Seeing it on every knife has me a bit stumped. A lot of knives often aren't even to begin with... they may look equal but are often offset to one side. You can usually see it by looking down on the tip from the spine side, or at the heel from the edge side. If you're measuring angles, checking for straightness, etc. this is the only thing I can think of, but I'm not sure it would be that consistent on every knife.

You could double check and make sure the sharpener is assembled correctly... the angle arm is 90 deg. to the base, etc. Haven't seen a problem in this area before... but if you're accurately measuring everything, it's the only other thing that comes to mind.
The administrator has disabled public write access.

Re: Question 1 year 6 months ago #10168

  • MarkMassie
  • MarkMassie's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 43
  • Thank you received: 3
  • Karma: 0
cbw34,

Thanks for your reply. I double checked and the clamp and angle arm are perfectly square with the base. However when looking everything over, I noticed that the right side clamp is not square with the left clamp and in fact it is curved backwards. I have been thinking about this and cannot determine if this could be contributing to the issue. I have tried to attach a file that shows what I am talking about, but I am not sure if I was successfule or not.

Thanks,

Mark
Last Edit: 1 year 6 months ago by MarkMassie.
The administrator has disabled public write access.

Re: Question 1 year 6 months ago #10169

  • MarkMassie
  • MarkMassie's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 43
  • Thank you received: 3
  • Karma: 0
I apologize, but the picture is backwards in the that when on the base, it it actually the right half of the clamp that is not square at the top. In addition, the right side of the clamp is a little taller than the left side and this may be due to the bend - not sure.
The administrator has disabled public write access.

Re: Question 1 year 6 months ago #10171

  • cbwx34
  • cbwx34's Avatar
  • OFFLINE
  • Moderator
  • Posts: 1260
  • Thank you received: 413
  • Karma: 92
Yessir... I believe that clamp needs to be replaced. That's probably the reason!

Contact This email address is being protected from spambots. You need JavaScript enabled to view it. , and he can make arrangements to get you a replacement.

Also, I sent you a private message, you may want to check.
The administrator has disabled public write access.

Re: Question 1 year 6 months ago #10172

  • MarkMassie
  • MarkMassie's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 43
  • Thank you received: 3
  • Karma: 0
Here are the pictures - I hope.

Thanks,

Mark
Attachments:
The administrator has disabled public write access.
Time to create page: 0.123 seconds